HSRPを組む時はgroup numberに注意

 16, 2009 18:54
別々のHSRPを設定したルータが複数台あるときに、配線ミスをすると通信上致命的な問題になる事があります

・・・というか先日、配線ミスが原因で複数のHSRPが混在し、デフォルトゲートウェイとなるIPアドレスの奪い合いが発生しました。

後日、検証のために下記の設定でHSRPの動作を確認。

■ルータ1
!
interface Vlan10
ip address 1.1.1.1 255.255.255.0
standby 0 ip 1.1.1.2
standby 0 priority 120
standby 0 preempt
!

■ルータ2
!
interface Vlan10
ip address 10.10.0.2 255.255.255.0
no ip redirects
standby 0 ip 10.10.0.1
standby 0 priority 110
standby 0 preempt
standby 101 ip 10.10.0.254
standby 101 priority 110
standby 101 preempt
!

■出力されたエラーログ
%HSRP-4-DIFFVIP1: Vlan10 Grp 0 active routers virtual IP address 1.1.1.2 is different to the locally configured address 10.10.0.1


■ルータ1から見て
#sh standby brief
P indicates configured to preempt.
|
Interface Grp Pri P State Active Standby Virtual IP
Vl10 0 120 P Active local 10.10.0.3 1.1.1.2


■ルータ2から見て
#sh standby brief
P indicates configured to preempt.
|
Interface Grp Pri P State Active Standby Virtual IP
Vl10 0 90 P Standby 1.1.1.1 local 10.10.0.1
Vl10 101 110 P Active local unknown 10.10.0.254


Grp0はpriorityが高い方のVirtual IPが有効になり、priorityが低い方のVirtual IPは無効になります。
(Standby状態になるので)

つまりgroup番号が同じ場合は、ネットワークセグメントが異なっていてもpriorityが高い方のVirtual IPしか利用できなくなりますので、同一敷地内などで複数のHSRPを稼動させている場合はgroup番号も異なるように設計する必要があります。

(group番号が異なれば影響は受けません)

普通、そんなネットワーク環境を構築しないと思うので遭遇する事はまれだと思いますけれど・・・

Tag:HSRP


COMMENT 0


WHAT'S NEW?