CiscoのNAT環境下で鬼門であるTV会議システムの設定

 02, 2009 20:37
NATを適用している拠点から、TV会議システムを利用する必要があり色々調べた時の簡単なメモ書きです。

結論から言うと、ネットワーク機器側の設定だけで対処できる問題ではなく、
TV会議システム自体でNATに対応している事が必要です。
(殆どの機器で対応自体はしているようですが、動くとは別問題?)

PolycomのTV会議システムでは、型番の組み合わせによって出来る端末と出来ない端末がありました。
(ファームのバージョンは揃えましたけれど、出来たり出来なかったり)

■構成の概略
TV会議端末の実アドレス :192.168.0.10
NATで外部に見せているアドレス :10.10.0.10

外部 ? NATルータ ? ルータ ? TV会議端末



■Cisco設定
StaticでNATを設定。
NATしたアドレスに対してStaticルーティングを併せて設定。
ip nat service以下設定は効果無しでした。

ip nat service H225
ip nat service allow-h323-keepalive 等

interface FastEthernet0
ip address 192.168.1.1 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet1
ip address 10.1.0.1 255.255.0.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
ip route 192.168.0.0 255.255.0.0 192.168.1.2
ip route 192.168.0.10 255.255.255.255 10.10.0.10
!
ip nat service allow-h323-keepalive
ip nat outside source static 10.10.0.10 192.168.0.10 extendable

後はルータ間でのルーティングをまわして、最低限pingの疎通を確認

■TV会議端末の設定(Polycomの場合)
設定メニューから、「ファイアウォール/LAN接続」の設定画面を呼び出し、
固定ポートを使用 : チェック
TCPポート : 3230?3231
UDPポート : 3230?3235
システムはNATの後方 : チェック
H.460ファイアウォール越えが可 : チェックを外す
NATはH.323対応 : チェックを外す
NATの自動検出 : チェックを外す
NATの外部(WAN)アドレス : ルータの外部アドレス
(NATのパブリックアドレス)


色々調べて一番簡単な解決策は、ルータにセカンダリIPアドレスを割り振って
TV会議端末だけ別アドレス体系に逃がしてしまう手法という残念な結果。

原因の切り分けに時間を割く手間暇を考えると仕方が無いとはいえ
お粗末かなと思いながら設定。

Tag:TV会議システム NAT


COMMENT 0


WHAT'S NEW?