ルータでEtherchannel 続き

 24, 2013 23:51
Port-channel3を作成して、VLANを割り当てるとsh etherchannel summary で状態が表示されました。

interface Port-channel3
switchport access vlan 100
no ip address

#sh etherchannel summary
Flags: D - down P - in port-channel
I - stand-alone s - suspended
R - Layer3 S - Layer2
U - in use
Group Port-channel Ports
-----+------------+-----------------------------------------------------------
3 Po3(SD)

ただそうすると物理ポートで設定が弾かれます。

#interface gigabitEthernet 0/1
(config-if)#channel-group 3
Channel-group 3 does not exist in config

VLANを割り当てるとLayer2のEtherchannelになってしまい、ルータのインターフェイスでは設定ができないという事なのかなと、試しにport-channel 4を定義してみると、やはりchannel-groupの設定は弾かれません。

#int port-channel 4
(config-if)#exit
(config)#int gi 0/1
(config-if)#channel-group 4


sh runで設定を見る以下のように設定されています。

!
interface Port-channel3
switchport access vlan 100
no ip address
!
interface Port-channel4
no ip address
hold-queue 300 in
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
~~
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
channel-group 4



しかしsh etherchannel summary を見るとPort-channel3の状態しか確認できません。

L3のEtherchannelってsh etherchannel summaryでは表示されないのかと思ったりしましたが、
Flags:
R - Layer3
と表記されているので、謎です。

# sh etherchannel summary
Flags: D - down P - in port-channel
I - stand-alone s - suspended
R - Layer3 S - Layer2
U - in use
Group Port-channel Ports
-----+------------+-----------------------------------------------------------
3 Po3(SD)


ルータでEtherchannelを組んだことがなかったのですが、悩む羽目になるとは思いませんでした。

COMMENT 0


WHAT'S NEW?