EtherChannel関係の注意事項

 12, 2009 22:49
EtherChannelでtrunk追加時にインターフェイス断を発生させてしまったので、注意事項としてメモ

※EtherChannelの論理インターフェイスに元々Trunkを通す設定が必要なのか特に検証せず、
既存設定を踏襲してそのまま追加したしたらはまりました。迂闊


■EtherChannelを適用するインターフェイスを設定

switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
switch(config)#interface range GigabitEthernet0/1 - 2 ←EtherChannelを行うインターフェイスをまとめて設定
switch(config-if)#channel-group ? ←作成できるEtherChannelの数を確認できます
<1-6> Channel group number

switch(config)#channel-group 1 mode on
Creating a port-channel interface Port-channel 1

switch(config)#switchport access vlan 10
switch(config)#switchport trunk allowed vlan 10 ←trunkを予め通しておくとVLAN追加時に断が発生しないので便利
switch(config)#switchport mode trunk



■EtherChannelの論理インターフェイスを設定
Switch(config)#interface Port-channel1
Switch(config-if)#switchport access vlan 10
Switch(config-if)#switchport trunk allowed vlan 10
Switch(config-if)#switchport mode trunk


■コンフィグ(トラブル発生前のコンフィグ)
interface Port-channel1
switchport access vlan 10
switchport trunk allowed vlan 10
switchport mode trunk
!
interface GigabitEthernet0/1
switchport access vlan 10
switchport trunk allowed vlan 10
switchport mode trunk
channel-group 1 mode on
!
interface GigabitEthernet0/2
switchport access vlan 10
switchport trunk allowed vlan 10
switchport mode trunk
channel-group 1 mode on
!


■この状態でtrunkを追加する際、物理インターフェイス側を先に設定すると
下記のようなエラー出力がされEtherChannelのインターフェイスがダウンします

Gi0/1 is not compatible with Po1 and will be suspended (vlan mask is different)


つまりtrunkを追加するなら表示されるコンフィグ順に追加すれば問題なし、という事です

interface Port-channel1
switchport trunk allowed vlan add 20
interface range GigabitEthernet0/1 - 2
switchport trunk allowed vlan add 20


関係ないけれどCiscoではEtherChannelと呼ぶのに、なぜ設定はport-channelなんでしょう。
たまに呼び方を間違えてしまいます。
(話は通じますけれど)

Tag:EtherChannel


COMMENT 0


WHAT'S NEW?