Ciscoの冗長化構成におけるメモ(HSRP)

 20, 2009 18:55
Ciscoルータで設定したHSRPに関してのメモ書きです。

■HSRPの状態確認コマンドは show standby briefが見やすくて便利です。
#show standby brief 
P indicates configured to preempt.
|
Interface Grp Prio P State Active Standby Virtual IP
Vl10 10 110 P Active local 192.168.0.3 192.168.0.1


#show standby
Vlan10 - Group 10
State is Init (interface down)
Virtual IP address is 192.168.0.1
Active virtual MAC address is 0000.0c07.ac0a
Local virtual MAC address is 0000.0c07.ac0a (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 0.307 secs
Preemption enabled
Active router is local
Standby router is 192.168.0.3, priority 100 (expires in 7.718 sec)
Priority 110 (configured 110)
IP redundancy name is "hsrp-Vl10-10" (default)



■LAN側のACLを設定する場合、HSRPのHelloパケットを許可する必要があります。
※気付かないと、トラブルの元です。

HSRPで利用するHelloパケット 224.0.0.2宛のUDPポート1985 の許可を行います。

一般的な設定
(config)#access-list 100 permit udp any host 224.0.0.2 eq 1985


■ルータ3台でHSRPを組む場合。
一番プライオリティが低い機器がListen状態とのままとなり、
1台が落ちると、一番プライオリティが低い機器がStanbyに変更となります。
3台で冗長化することはまずないと思いますが、どのような動作になるのか
知っておいて損はないかなとおもいます。


設定例
ルータ1(Activeルーター)
interface Vlan10
ip address 192.168.0.2 255.255.255.0
standby 10 ip 192.168.0.1
standby 10 priority 110
standby 10 preempt ←preemptコマンド


ルータ2(Stanbyルーター)
interface Vlan10
ip address 192.168.0.3 255.255.255.0
standby 10 ip 192.168.0.1
standby 10 priority 100 ←標準の値なので設定する必要なし
standby 10 preempt

ルータ3(Stanbyルーター)Listen状態
interface Vlan10
ip address 192.168.0.4 255.255.255.0
standby 10 ip 192.168.0.1
standby 10 priority 90
standby 10 preempt


上記の例にもありますがpreemptコマンドが設定されていないと、
最初にActiveルータになったルータがActiveのまま動作する事となります。
preemptコマンドが設定されていれば、プライオリティが高いルータを検知したら
プライオリティが高いルータがActiveに変更されます。

停電復旧時など、起動順序によって意図しないルータがActiveとなる事になるので
入力必須の機能ではないでしょうか?
(なんで標準設定になっていないのだろう、と思います)

Tag:HSRP


COMMENT 0


WHAT'S NEW?